Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 12

Тема: Помогите разобраться с BOOT в тюнере AB IPBox200s.

  1. #1

    Помогите разобраться с BOOT в тюнере AB IPBox200s.

    Доброго времени суток уважаемые форумчане. Прочитав не один форум по этой теме решил написать.Принесли данный тюнер с просьбой установить русский язык.Он в нём был,но клиент произвёл сброс на заводские настройки и русский язык слетел в энигме.Изначально зайдя в меню информации прочитал следующее.Dream Multimedia.TV. DM5620.Release 4.4.0.27.05.2008.Linux 2.6.17.mutant200s.Release 0440.На материнской плате написано Mutant-200s ver c.(2005.12.01) Не имея опыта работы с данным тюнером прошил его первой попавшейся прошивкой и получил на дисплее 8.8.8.8.Дальше процесс загрузки не продвигался,но в режим SERL аппарат мог входить.Найдя нужную информацию прошил его официальным софтом. Сначала загрузчик AB_IPBox200S_2.17_serial_uboot,затем имидж AB_IPBox200S_2.17_serial_all.Тюнер ожил.Я произвёл все настройки немного его погонял и оставил в режиме ожидания на ночь.По утру его выключил.На следующий день заказчик попросил добавить Хотбёрд и сделать фаворитный список.Всё это было с успехом проделано.Оставив его опять на ночь в режиме ожидания по утру при нажатии на пульте кнопки включения тюнер дальше режима BOOT перестал грузиться.После этого в тюнер можно залить только один имидж hl217_200s_pal_serial_kernel_root_db который проходит все стадии загрузки 100%.ERAS,FLAS,DONE.Естественно перед заливкой этого имеджа я заливал загрузчик 200S_serial_uboot_enigma_rel1.2.А так же Welcom имидж welcome_AB_IPBox200S.И при перезагрузке тюнера видел опять всё тот же BOOT.Оригинальный имидж и другие перестали вообще прошиваться.Процесс доходит до 99%,а дальше EROR.Вот лог загрузки ресивера U-Boot 1.2.0 (Oct 5 2007 - 20:59:57)

    CPU: IBM PowerPC STBx25xx(51510950) at 252 MHz (PLB=63)
    16 kB I-Cache 8 kB D-Cache
    Board: relook100s
    I2C: ready
    DRAM: 24.6 MB
    FLASH: 8 MB
    *** Warning - bad CRC, using default environment

    checking welcome image... ok.
    gzip compressed welcome image.
    default for stv6412
    default for rfmod
    Un-Protect Flash Bank # 1
    Press esc to debug bootloader.
    booting...
    Data (writethrough) Cache is ON
    ## Booting image at ff840000 ...
    Image Name: Linux Kernel Image
    Image Type: PowerPC Linux Kernel Image (gzip compressed)
    Data Size: 1062839 Bytes = 1 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... OK
    Uncompressing Kernel Image ... OK. Из лога видно что не запускается ядро Линукса.Как мне выйти из данной ситуации?Помогите пожалуйста.Работа усложняется ещё тем,что в тюнере нет сетевой карты.Её сняли после того, когда она была повреждена во время грозы.Сам же ресивер не один год после этого работал с тётей шурой с помощью компьютера.На ваш взгляд это программный глюк или уже начались проблемы с железом?Блок питания проверил.Напряжения в норме.Конденсаторы по проверял на приборе Е7-15.Подозрительных не было,но по цепи +3,3в и +5в поменял на новые.

  2. #2
    Senior Member
    Регистрация
    13.12.2006
    Сообщений
    2,335
    Добрый день.

    Или вы опечатались, или я не понял - Вы пишете что для официального имиджа заливали загрузчик 200S_serial_uboot_enigma_rel1.2, но это для энигмы загрузчик.
    Если ничего не помогает и что-то слетело, то попробуйте еще прошить ресивер с помощью jtag: http://ipbox.com.ua/showthread.php/3...BD%D0%B8%D0%B5
    там в теме поищите - есть и схема выложена и инструкции и проги для восстановления.
    Прога на 10-й странице темы.
    Мне правда попадались экземпляры ресиверов, у которых флеш уже полуживая - восстанавливаются но потом все равно перестают работать.
    Последний раз редактировалось janigor; 13.11.2014 в 09:40.

  3. #3
    Цитата Сообщение от janigor Посмотреть сообщение
    Добрый день.

    Или вы опечатались, или я не понял - Вы пишете что для официального имиджа заливали загрузчик 200S_serial_uboot_enigma_rel1.2, но это для энигмы загрузчик.
    Если ничего не помогает и что-то слетело, то попробуйте еще прошить ресивер с помощью jtag: http://ipbox.com.ua/showthread.php/3...BD%D0%B8%D0%B5
    там в теме поищите - есть и схема выложена и инструкции и проги для восстановления.
    Прога на 10-й странице темы.
    Мне правда попадались экземпляры ресиверов, у которых флеш уже полуживая - восстанавливаются но потом все равно перестают работать.
    Добрый день.Фирмваре я брал отсюда http://download.abcom.sk/index.php?&...20-%20Firmware надеюсь оно там оригинальное.А загрузчик 200S_serial_uboot_enigma_rel1.2 действительно для энигмы.Но только с ним удаётся прошить вот этот имидж hl217_200s_pal_serial_kernel_root_db.Любой другой серии all загружаться не хочет.Пишет EROR.JTAGом прошивал.Программкой именно с 10 странички. Затем имидж AB_IPBox200S_2.17_serial_all.В нём есть свой загрузчик,но выскакивает после 99% EROR.Также пробывал и JTAG1.3.Результат тот же. На обеих версиях джитага доунлоуд доходит до 81% затем резко добавляются точки пишет done и complit.Может процесс загрузки должен доходить до 100%?Может нужно прошить фирмваре более ранней версии,но у меня такого имиджа нет,а в нэте не встречал.На сайте http://www.ab-forum.info/viewforum.php?f=22 зарегистрироваться не получается.Пишет неверный ответ на контрольный вопрос.Думаю у вас опыта по больше.Может посоветуете какой загрузчик и с каким имиджем лучше попробывать залить.

  4. #4
    Senior Member
    Регистрация
    13.12.2006
    Сообщений
    2,335
    Выложу загрузчик для официального софта и официальный последний софт что нашел у себя.
    Вложения Вложения

  5. #5
    Senior Member
    Регистрация
    13.12.2006
    Сообщений
    2,335
    Загрузчик для энигмы и энигма от sifteam
    Вложения Вложения

  6. #6
    Цитата Сообщение от janigor Посмотреть сообщение
    Загрузчик для энигмы и энигма от sifteam
    Спасибо janigor за внимание и файлы.Увы ни одна из пар не загрузилась в ресивер.Опять после 99%закачки имиджа высветилась ERROR.Вот лог загрузки. U-Boot 1.1.1 (May 31 2007 - 22:26:10)

    CPU: IBM PowerPC STBx25xx(51510950)
    Board: relook100s
    I2C: ready
    DRAM: 22 MB
    FLASH: 8 MB
    *** Warning - bad CRC, using default environment

    partition "db" selected.(ffd60000,270000)
    Partition changed to 3
    ### JFFS2 loading 'init.denc.uboot' to 0x10
    Scanning JFFS2 FS: .. done.
    find_inode failed for name=init.denc.uboot
    load: Failed to find inode
    ### JFFS2 LOAD ERROR<0> for init.denc.uboot!
    init.denc.uboot load fail
    checking welcome image... ok.
    gzip compressed welcome image.
    Partition changed to 3
    ### JFFS2 loading 'init.stv6412.uboot' to 0x10
    ### JFFS2 load complete: 170 bytes loaded to 0x10
    ## Executing script at 00000010
    ### JFFS2 loading 'init.rfmod.uboot' to 0x10
    ### JFFS2 load complete: 100 bytes loaded to 0x10
    ## Executing script at 00000010
    Un-Protect Flash Bank # 1
    Press Ctrl-z to debug bootloader.
    booting...
    Data (writethrough) Cache is ON
    ## Booting image at ff840000 ...
    Image Name: Linux Kernel Image
    Image Type: PowerPC Linux Kernel Image (gzip compressed)
    Data Size: 1062839 Bytes = 1 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... OK
    Uncompressing Kernel Image ... OK
    Загрузчик официальный 200s_pal_215_and_up_serial_uboot.rar и скорее всего имидж hl217_200s_pal_serial_kernel_root_db,который остался в памяти флеши и не стёрся при загрузке.Круг замкнулся.А можно ли как то через консоль загрузчика проверить работоспособность флеши а может даже и всего железа.?

  7. #7
    Senior Member
    Регистрация
    13.12.2006
    Сообщений
    2,335
    Жтаг попробовать с шнурком короче. Или там есть параметр больше таймаута.
    Должен отсчет быть до 100%.
    Больше у меня нет идей

  8. #8
    Цитата Сообщение от janigor Посмотреть сообщение
    жтаг попробовать с шнурком короче. или там есть параметр больше таймаута.
    должен отсчет быть до 100%.
    больше у меня нет идей
    у меня длина шлейфа от разъёма лпт до тюнера 20см.плюс шлейф внутри компа от материнки до планки с разъёмом.а где смотреть и как менять этот параметр,который больше таймаута?скажу честно про таймаут читал,а понятие про него относительное имею.уже нашёл где менять время таймаута,плюс ко всему у меня стоял режим работы lpt порта отличный от ecp.завтра укорочу немного ещё шлейф и буду пробовать прошивать jtag1.4.
    Последний раз редактировалось Stas1969; 13.11.2014 в 22:54.

  9. #9
    добрый день.вот и закончились опыты.укоротил шлейф до 8 см.резисторы впаяны непосредственно в плату.время таймаута пробовал как 3 так и 1 в режиме ecp.также включал нормальный режим параллельного порта.а воз и ныне там.всё те же 81% при записи.из идей ещё у меня появилась мысль поменять адрес параллельного порта и попробовать сделать программатор на микросхеме.

  10. #10
    Senior Member
    Регистрация
    13.12.2006
    Сообщений
    2,335
    Печально.
    Может ресивер пора сменить?

Страница 1 из 2 12 ПоследняяПоследняя

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •